icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.yygjjd.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

彩8彩票 www.341131.com-疾风彩票计划| www.1724.cc-彩神这个软件好吗| www.458855.com-足彩竞猜贴吧| www.626135.com-698彩票网-| www.753105.com-彩票12安全吗| www.899407.com-投注彩票软件下载| www.963902.com-黑彩票大全-| www.03660.com-爱尚彩下载-| www.139552.cc-共亨彩票资料大全| www.027129.com-078彩票平台登录| www.92mh.cc-彩票性缘完整版| www.540245.com-国外有足球彩票吗| www.25893.cc-周杰伦彩虹-| www.246369.com-江苏省体彩中心号码| www.420466.com-广州市福利彩票地址| www.550813.com-互联网彩票导航| www.654410.com-南昌自助彩票机| www.59491.com-体彩5d的开奖号| www.6294.org-手机彩票刮刮卡| www.28534.com-福彩助手客户端下载| www.793718.com-利民彩票网靠谱吗| www.225157.com-保时捷彩票登录| www.712097.com-e球彩票怎么买| www.856503.com-彩果游戏全民竞技| 500彩票网www.607335.com| www.03sz.com-彩库品牌女装官网| www.697.cc-怎么查询足彩受注量| www.6898.win-好彩头公司电话| www.25824.com-体育彩票直播开奖| www.610295.com-油性彩铅上色教程| www.30022.com-亿彩怎么获取邀请码| www.773452.com-安卓彩票缩水软件| www.365336.cc-体彩排列三和尾走势| www.fd18.com-百彩网手机资料| www.u74.net-新彩吧推荐号| www.2743.com-福利彩票最多多少倍| www.367802.com-彩谜天地报纸| www.994177.com-网上彩票赚钱平台| www.kt87.com-快三甘肃开奖今天| www.l72.net-彩81彩票下载安装| www.887878.com-106彩票投注网站| www.a41.net-北京福彩开奖查询| www.625193.com-e球彩的奖金| www.751422.com-彩票站最高邀请码| www.865350.com-中国彩票图片| www.hm14.com-足彩2串1全包保本| www.03wb.com-tt彩票平台可靠吗| www.791866.com-幸运博彩app下载| www.106122.com-掌上彩票官方网站| www.9418.top-中国彩票害惨彩民| www.254289.com-湖壮福彩快3| www.345773.com-高频彩票开奖直播网| www.438155.com-鹤岗彩票站出兑| www.542178.com-360彩票网购大厅| www.5675.top-韩国彩票中了4个号| www.587795.com-6合万彩1-| www.281925.com-今日彩票预测中奖号| www.64002.com-足球竞彩新浪网| www.664939.com-彩民之家a图| www.41215.com-二元彩票走势| www.142220.com-中彩网免费资料大全| www.958419.com-彩99下载安装苹| www.zs2.com-大发快三口诀| www.032357.com-彩票137网站| www.017913.com-英国5星彩-| www.088051.com-双赢彩票手机版登录| www.153258.com-时时彩定位杀号方法| www.802168.com-福利彩票销售站号| www.879535.com-大智慧彩票平台| www.379112.com-体彩图谜第四版| www.388820.com-彩票软件辅助| www.3099.me-世界杯彩票买不了| www.711646.com-时时彩个位杀号技巧| www.848775.com-彩光嫩肤美容| www.k98.win-91彩神是真的| www.4942.vip-d9彩票登录-| www.36981.cc-体彩排列三字谜区| www.89727.com-2019年4月足彩| www.056046.com-搜狗七星彩梦册解梦| www.353333.com-下载京彩7515| www.526.mobi-中国移动手机彩票网| www.09001.com-微信怎么买福利彩票| www.58886.cc-竞彩预测网易| www.023861.com-下载彩报和彩迷图| www.129724.com-中奖彩票新闻| www.432647.com-新浪官网首页彩票| www.575152.com-福利彩票三加零| www.698263.com-黑金博时时彩计划| www.793060.com-绵阳福彩申请电话| www.033074.com-河内5分彩官网| www.00cg.com-七彩乐透开奖结果| www.797971.com-体彩竞彩源码| www.905766.com-足彩14场比分直播| www.994586.com-福彩三的走势图| www.339649.com-彩导航威尼斯| www.0842.net-网上可以买足彩么| www.149510.com-百万彩票官网| www.715769.com-龙江福彩22选5| www.827799.com-天天彩票信用卡充值| www.967857.com-彩票走势探探| www.gd49.com-快三投注技巧最佳| www.629153.com-竞彩天天-| www.731660.com-彩妆店的加盟| www.620706.com-香港马彩经资料| www.9399.bid-体育足球彩票怎么看| www.349732.com-体彩和福彩哪里买| www.551565.com-联众彩票是正规的么| www.579758.com-体彩19069期| www.3979.bid-49彩票开奖结果| www.57500.cc-怎样下载双色球彩票| www.731650.com-百姓彩票返钱快吗| www.897291.com-美国彩票各州州税| www.081530.com-彩多多官网-| www.261468.com-三d刺客论坛研彩网| www.880825.com-十分彩玩法-| www.987620.com-汇彩网登录主页| www.rh56.com-极速时时彩官方开奖| www.020512.com-中华彩票开机号| www.2233.hk-诺亚国际彩票| www.02931.com-35彩票计划-| www.70033.cc-时时彩杀码秘诀| www.026413.com-快三开奖一注多少钱| www.121668.com-彩专家5码2期计划| www.208187.com-福利彩票11选五| www.348168.com-大乐透文集乐彩网| www.229729.com-app彩票-| www.235973.com-体彩排三直选遗漏| www.343099.com-32彩票手机app| www.08vt.com-彩票中奖人物| www.399567.com-南国体育彩票| www.703272.com-彩票双色球随机一注| www.880179.com-福彩大脑袋杀码专家| www.971227.com-球探彩票app| www.rw55.com-时时彩输了怎么上岸| www.78gk.com-祝你发财彩票网| www.002359.com-360足球竞彩网| C9999www.318548.com| www.237548.com-幸运快三全天走势图| www.53yu.com-毕节体育彩票| www.586882.com-天津快三怎么玩稳赚| www.7jm.com-用家人生日买彩票| www.2444.in-体彩大乐透假不假| www.78821.com-彩吧彩票注册邀请码| www.520697.com-精准七星彩头尾推荐| www.000479.com-彩票103安卓版| www.164810.com-高频彩真的有漏洞| www.981139.com-87竞彩官方网站| www.mb25.com-江苏快三怎么玩的| www.36zu.com-uk彩是啥-| www.1380.cm-奔驰彩票靠谱吗| www.09952.com-山东福利彩票地址| www.411592.com-ios12原彩没了| www.38268.cc-河北福彩双色球| www.000447.com-亚博足彩app好吗| www.102338.com-快开彩12选5| www.204218.com-彩迷app-| www.330978.com-人人中奖彩票真实吗| www.508338.com-同乐彩票appp| www.633787.com-七彩教育理念| www.606906.com-福彩票无人彩票机| www.712477.com-快三怎样玩不会输| www.821244.com-十分彩网app| www.932750.com-致富彩票是不是真的| www.62qo.com-足球竞彩人工智能|